Polished Chrome 2-Handle 4" Centerset Bathroom Faucet

Pfister FWL2230C
Classic Collection

Available in 2 Color(s)

Features

  • Meets ADA/ANSI A117.1 requirements, ensuring accessibility to all disabled persons
  • Complies with Federal and State safe drinking water legislation.
  • Meets or exceeds EPA WaterSense Standards, which reduces water consumption by 30% and helps average households save up to $200 in their annual water bill
  • Faucet mounted on sink deck or countertop

Quick Specs

  • Type: Bathroom Faucets

See More

 

by Pfister

The Classic Series, an entry-level product line, is designed to enhance installation and offer Price Pfister quality at an affordable price. It offers a compelling chrome finish with simplified styles to match every kitchen decor.

View All

The Classic Series, an entry-level product line, is designed to enhance installation and offer Pfister quality at an affordable price.

Features

  • Meets ADA/ANSI A117.1 requirements, ensuring accessibility to all disabled persons
  • Complies with Federal and State safe drinking water legislation.
  • Meets or exceeds EPA WaterSense Standards, which reduces water consumption by 30% and helps average households save up to $200 in their annual water bill
  • Faucet mounted on sink deck or countertop
  • TiteSeal™ Mounting Technology eliminates the need for putty or silicone and simplifies installation
  • Pfast Connect™ reduces installation time and guarantees a secure connection to water supply lines
  • Retail exclusive faucet
  • Includes valve and cartridge
  • 3-hole installation
  • Features an all plastic pop-up drain assembly
  • Rated to meet or exceed CALGreen criteria, which helps to conserve water in the average home by at least 20 percent
GPM Flow Rate 1.5
# of Handles 2
Deck To Aerator Height 1.875
Drain Assembly American All Plastic
Soap Dispenser No
Configurations 3-Hole

Quick Specs


  • Appearance

  • Type: Bathroom Faucets

Instruction Sheet

Specification Submittal

Parts Diagram

Get Adobe Reader

* Documents require Adobe Reader.